bundled (2.0.34 compatible)